Remove Yumpu branding on the embed player

Hi there.

I’m uploading a pdf using the api. As far as I know, there is no way to disable Yumpu branding (I have a ‘premium’ level which allow me to do it on the web page).

I can set the property player_branding =n but the Yumpu logo is still visible on the embed player, before viewing the document in full screen mode.

Is it possible to set the yumpu logo to not visible within the api ? (I already read the documentation at least 10 times)

Yumpu User Asked on November 7, 2016 in Developer.
Add Comment
10 Answer(s)

({“state”:”failed”,”errors”:{“player_elements_logo”:{“message”:”Field \”player_elements_logo\”: Not allowed”}},”completed_in”:0.0424}).

Yumpu User Answered on November 11, 2016.
Add Comment

I try and it does not work. ({“state”:”failed”,”errors”:{“player_elements_logo”:{“message”:”Field \”player_elements_logo\”: Not allowed”}},”completed_in”:0.0424}).

Do you have another idea ?

Yumpu User Answered on November 17, 2016.
Add Comment

I still have this issue, Linus, can you please check with your dev team ?

Yumpu User Answered on February 20, 2017.
Add Comment

Hello David,

thank you for your message.

Please have a look at this: Document -> Post file -> player_branding

RE: Remove Yumpu branding on the embed player

request:
curl -X POST -H “X-ACCESS-TOKEN: XYZ” -F “file=@file.pdf” -F “title=My title” -F “player_branding=n” “http://api.yumpu.com/2.0/document/file.json”

Best regards

Maria

Yumpu Support Answered on February 22, 2017.
Add Comment

Maria,

No it doesn’t work.

I still have the “Yumpu” Logo on the embed player. Please contact me by email if you need more information to understand clearly my issue.

Yumpu User Answered on February 22, 2017.
Add Comment

Hello David,

well, we are talking about two different topics:

  1. Uploading a PDF using the API -> without Yumpu branding
  2. Disabling Yumpu branding in the embed wizard

To disable the Yumpu branding in the embed wizard you have to set the “PLAYER-ELEMENTS” -> Logo to “no”:

RE: Remove Yumpu branding on the embed player

You can also contact us at support(at)yumpu.com

Best regards

Maria

Yumpu Support Answered on February 23, 2017.
Add Comment

Ok Maria, let me be crystal clear : I want to disable the player-elements logo  using the API. I got previously an answer from Linus which didn’t work.

I don’t want to login yumpu WebApps to manually set the property to ‘no’.

Please read this thread, you will understand my needs.

 

 

Yumpu User Answered on February 23, 2017.
Add Comment

Hello David,

try this -> First post your new magazine and then post the new embed code.

either: Post File
or: Post URL
then: Progress Get

then: Post embed -> with  “player_branding=n”

Best regards

Maria

Yumpu Support Answered on February 23, 2017.
Add Comment
    1. This is not documented on the Post embed page
    2. I got an error “Not allowed” on the player_branding parameter

      curl -X POST -H “X-ACCESS-TOKEN: MY TOKEN” -d “document_id=MY ID” -d “type=2” -d “width=500” -d “background_shape=square” -d “color=grey” -d “player_branding=n” -d “destination=http://www.yumpu.com” “http://api.yumpu.com/2.0/embed.json”

       

      {“errors”:{“player_branding”:{“message”:”Field \”player_branding\”: Not allowed”},”destination”:{“message”:”Field \”destination\”: Value magazinePage or magazine”}},”state”:”failed”,”completed_in”:0.0404}

    3. Have you tried first ?

    4. The Post File resource has a player_branding parameter which seems ignored. More, the embed exists even the Post embed resources is not called. I can extract if from the documentProgressGet resource.

    5. Please contact me by email to solve this issue, this chat here is not really convenient

 

Yumpu User Answered on February 23, 2017.
Add Comment

Hello David,

thank you for your answer.

To disable the yumpu branding -> you will need at least an adFREE plan.

Best regards

Maria

Yumpu Support Answered on February 28, 2017.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.